Register and join the discussion

1994 wont shift into 4 wheel high


meuhus
11-27-2007, 04:02 PM
1994 s-10 blazer wont shift into 4 wheel high
will go into low
both lights come on on the switch
when it is in low and some times they light up
on there own
sound like the motor is working
but wont go into high

MT-2500
11-28-2007, 09:58 AM
http://www.automotiveforums.com/vbulletin/showthread.php?t=572914

MT-2500
11-28-2007, 11:24 AM
You forgot to tell us you had the transfer case with the green light.
And that you had another post.
Disregard the link I posted because we need to know what transfer case you have.
Post back the tag no off of your transfer case.
If you still have the owners manual read it.
There is a certain way you push the gree shift button on it like maybe two times in a row.

garyturner2
11-28-2007, 01:42 PM
Hey,

So I kind of have the exact same problem and i am in the process of fighting with a mechanic to get it fixed. Like six months ago i the truck stopped shifting into 4 high but 4 lo and 2 hi would still work. At the time we were constantly using 4wheel drive becuase we go on the beach a lot, but we would always use 4lo and keep it to tem MPH. well one day it just wouldnt shift into anything but 4 lo. we had to limp the truck to a mechanic and they had to replace the transfercase shifter moter and then rebuild the transfer case because everthing had gotten so messed up. after the MX every thing worked fine untill a few weeks ago. once again the transfer case will only goint 4lo and 2 hi. we took it back to the mechanic because i dont think it should break like that again so soon but he said the warrenty for the TCase was only good for 90 days. hence the reason i am in a fight with the mechanic right now. does anyone know what the problem might be because i really dont want to pay another 1300 dollars to fix it a second time in 6 months. thanks

MT-2500
11-28-2007, 02:06 PM
Hey,

So I kind of have the exact same problem and i am in the process of fighting with a mechanic to get it fixed. Like six months ago i the truck stopped shifting into 4 high but 4 lo and 2 hi would still work. At the time we were constantly using 4wheel drive becuase we go on the beach a lot, but we would always use 4lo and keep it to tem MPH. well one day it just wouldnt shift into anything but 4 lo. we had to limp the truck to a mechanic and they had to replace the transfercase shifter moter and then rebuild the transfer case because everthing had gotten so messed up. after the MX every thing worked fine untill a few weeks ago. once again the transfer case will only goint 4lo and 2 hi. we took it back to the mechanic because i dont think it should break like that again so soon but he said the warrenty for the TCase was only good for 90 days. hence the reason i am in a fight with the mechanic right now. does anyone know what the problem might be because i really dont want to pay another 1300 dollars to fix it a second time in 6 months. thanks

Welcome to AF.

It is best to start your own post.
Hit the New Thread buttion and give us all of the info including what transfer case it has.
Good Luck MT

meuhus
11-30-2007, 05:00 AM
yes it does have a green light and an amber or yellow light
it worked fine last year
truck has about 250,000 on it
it has one switch to work both 4wheel low and high
you push on the top part of the switch for hi (green)
and bottom for low(yellow)

i was mess around last night pushing the button
and got it stuck in 4 wheel low both lights light up when tring to
shift into 4 wheel drive low or hi
and the motor is not working at all now on transfer case
but i here the transfer case control modual working

MT-2500
11-30-2007, 09:40 AM
What transfer case?

meuhus
12-10-2007, 05:51 PM
it has a tag w/green lettering on it
i didn't get any numbers off of it
i got a case motor tried it but didn't work
so i took it back currently workin on
replacing elctric motor with manual shift

can anyone else help with an abs
problem?

i replaced the ball joints driver side
and when i put it back together left the wires for the wheel sensor up
to high and the rubbed on the rim
wore thru wires and all
i fixed the wires with crimp connectors
but abs light is still on
i checked the abs codes but i don't rember exactly what the codes were
one was wheel sensor and one might have been controller
i cant get the codes erased i ve disconected battery and pulled ecm fuse
left off and out for more than 10 minuates
how do you reset the abs computer?

MT-2500
12-10-2007, 06:04 PM
it has a tag w/green lettering on it
i didn't get any numbers off of it
i got a case motor tried it but didn't work
so i took it back currently workin on
replacing elctric motor with manual shift

can anyone else help with an abs
problem?

i replaced the ball joints driver side
and when i put it back together left the wires for the wheel sensor up
to high and the rubbed on the rim
wore thru wires and all
i fixed the wires with crimp connectors
but abs light is still on
i checked the abs codes but i don't rember exactly what the codes were
one was wheel sensor and one might have been controller
i cant get the codes erased i ve disconected battery and pulled ecm fuse
left off and out for more than 10 minuates
how do you reset the abs computer?

Pull fuse or unplug it to reset.
On ABS brakes.
We need the code no.
If it has codes you can not clear codes.
Post back code no.

Add your comment to this topic!