Register and join the discussion

'95 5.0 Throwing codes 181 189


g1smith
11-25-2007, 10:30 PM
My '95 5.0 is throwing codes 181 & 189

181 Adaptive fuel rich limit reached at part throttle, system lean, right side
189 Adaptive fuel rich limit reached at part throttle, system lean, left side

I've read that the problem lies with either the O2 sensor or the Mass Air Flow sensor. A vacuum leak could also cause this.

Anyone had any experience with this? I've sprayed carb cleaner on the MAF wire and changed the O2 sensors.

351wStang
11-26-2007, 09:15 AM
Well if you changed the O2's and that didnt do it then I say test the fuel pump.

g1smith
11-26-2007, 10:44 PM
Fuel Pump?
Been there ... done that, BTW what is that funky looking red thing on the return line mounted to the fuel sender? Looks kinda of like a flapper / a one way check valve to stop fuel vapor from going back to the fuel pressure regulator! Well a new one didn't come with the new pump. Should I worry? Sure why not!

I thought it was the fuel pump that was causing "long crank times" then finally a "no start" problem ... nope ... turned out to be the ignition module ... the thing AZ said mounts to the distributor but actually mounted to the fender underneath the Air filter / MAF sensor.

New MAF's are about $75 ... I guess it's cheaper that the stealer!
I just fixed a Land Rover Discovery II with a similar problem ... cleaning the MAF didn't stop the lean conditions, replaced the MAF and problems gone!

351wStang
11-28-2007, 09:49 AM
The ignition module/TFI module does mount to the side of the dizzy.

g1smith
12-01-2007, 02:43 PM
Thanks for the suggestion on the Fuel Pressure, my all-in-wonder vacuum-fuel pressure gage only goes to 8lbs. The manual suggests that fuel pressure should be around 35PSI. So I'll be visiting Harbor Freight soon :)

Not to be argumentative, but, my ignition/TFI module was mounted to a finned-heat sink and bolted to the fenderwell. All of the 1/4" sockets I had were too big in diameter to fit into the hole provided to reach the bolts ... had to drill 'em out ... and yes ... it was mounted to the fenderwell - I had to remove the Air Filter and the MAF to access it.

Here is a link to an article discussing the intermittent / no-start problem and the location of the TFI.

http://www.ashentep.com/webpages/mustanggt/1995_ford_mustang_gt.htm

Weird Start Problems

Its quite common with high mileage 5.0s to have a problem starting once the motor comes to temp, or other random starting problems. If you find your 5.0 won't start to save its life sometimes, but others start right away, there are two things to replace that should solve it for you. The first is the stator/pickup in the distributor. It senses when to fire the coil to send the spark to each cylinder. After some time this sensor becomes flaky and can cause these problems The other part is the ignition module. It usually causes problems after the car gets to operating temps. The stator is inside the distributor, and requires removal of the distributor gear, and pressing it back on. I was able to do this with my bench vise, but your results may vary. The ignition module is quite easy to replace, being a single plug and located on the fenderwell.
__________________
'74 Nova 350 4V - Rustoration Project - Runs

351wStang
12-01-2007, 11:49 PM
Thats good to know. Every 5.0 that I've ever payed attention to or looked for the TFI on had it mounted to the distributor. Even the SN95 cars. But, that car had MSD ignition so it may have been different.

TENGRAM
12-02-2007, 07:38 AM
check fuel pressure and check for vacuum leaks and exhaust leaks. did you run the Engine Running part of the test, or just the Engine Off/Memory code part? the rest of the codes may be helpful. let us know


BTW, if your MAF is stock and no codes are showing up indicating that it is the problem, don't replace it.

g1smith
03-10-2008, 09:58 PM
Thanks for all the suggestions ... It's fixed! It was the MAF!

I only did the Engine Off/Memory code check.

I went for a stock MAF ... I'd love to make it a racer but I'd rather feed the petrol to my other toys.

Add your comment to this topic!