Register and join the discussion

`92 supreme digital dash NOT WORKING


SteVB
07-27-2007, 07:38 AM
a female friend has my 92 cutlass supreme across country & had to have another friend change the water pump, thats fixed but now the digital dash is giving error codes & inaccurate, then completey went out since. anyone had this problem & fixed it? i dont have it here otherwise i could look at it myself, but i`m wondering if anyone ran into this? he said all he did was change the water pump, so nothing else was touched. i already told her to have the fuses checked, so thats going to be done.

XGamesJ6
07-28-2007, 11:01 AM
i think it happens with all digital dashes eventually. I saw something on Ebay, this guy sells a service, you send him your inst. cluster. and he'll fix it, and send it back, not sure what he does, but you get it back with the correct milege and such, granted u dont drive the car while u dont have the cluster there. It's either that, or he does and exchange, a fixed one for your old one. But im betting you can probably ask him to fix yours and send it back... http://cgi.ebay.com/ebaymotors/89-90-91-92-Oldsmobile-Cutlass-Supreme-digital-cluster_W0QQcmdZViewItemQQcategoryZ33675QQihZ017QQ itemZ270146980337QQrdZ1QQsspagenameZWDVW Theres a link to one of his auctions, I guess it never hurts to ask.

ead144
07-01-2008, 02:50 AM
I had the same problem on my 92 supreme. I removed the dash and touched up all the solder connections and the dash worked for about a year. Now the speedometer lights up but works intermittently.

Add your comment to this topic!