Register and join the discussion

89 1ton ECMB fuse keeps blowing. Need Urgent reply.


Fordy8man
11-29-2005, 08:57 PM
my dad is in florida cleaning up from the hurricanes, he called me and told me that the ECMB fuse keeps blowing and asked me if i could look it up for him. Its an 89 chevy 1ton (the old cab style) with a 87 or 88 motor and wire harness in it. any ideas on why the ECMB fuse keeps blowing would be greatful. thanks

locknkey
11-30-2005, 09:15 AM
My guess from what you stated unless the computer is beening used on the 87 or 88 motor and different wiring harness, the 89 was supposed to be a FI engine. Don't know if you are useing the same computer as before, or you swap out to a simple engine concept.
If the computer is only supposed to use the gages and other smog componants are removed...somewhere the computer is beening grounded from the curcuit thats blowing the fuse. Simply follow it out to see where its being connected to the ground connection, repair it, and replace the fuse. Don't try to "fix" something thats not broken, as it tends to make wires burn up thats not on a fused curcuit.

broughy84
11-30-2005, 05:09 PM
I am going to suppose this has a 350. 88, 89, 90, 91, 92, 93, 94, & 95 we all TBI, so I would say that you may be able to rule that out.

Fordy8man
11-30-2005, 05:43 PM
yes its a 350 FI. when replaced we used the same wiring harness and computer that was in the truck that the 350 came out of, so its all the same wiring and computer hooked to the motor.

broughy84
11-30-2005, 06:03 PM
Checked with my chilton's manual. Sorry it didn't have anything about the trucks ECMB fuse.....sorry I could help.

2000CAYukon
11-30-2005, 09:13 PM
Checked with my chilton's manual. Sorry it didn't have anything about the trucks ECMB fuse.....sorry I could help.

I have the 90 Factory Service Manuals and I could not find ECMB fuse either.

//2000CAYukon

Elbert
12-01-2005, 07:54 AM
my dad is in florida cleaning up from the hurricanes, he called me and told me that the ECMB fuse keeps blowing and asked me if i could look it up for him. Its an 89 chevy 1ton (the old cab style) with a 87 or 88 motor and wire harness in it. any ideas on why the ECMB fuse keeps blowing would be greatful. thanks


I had something similar happen. In my case one of the wires that feeds the TBI injectors under the air clearner got pinched between the air cleaner housing and the TBI extension. Which grounded out and caused the fuse to blow. Its worth opening the air cleaner and making sure you don't have any pinched wires or bare wirs that can short. The OEM desgin makes it easy for the injector wires to get pinched over time.

My truck is a 92 K1500 5.7 TBI

chevrock22
12-01-2005, 12:25 PM
Yes check the grounds.

borninski
12-01-2005, 11:37 PM
I had a similar problem:

1997 C1500 5.0L V8 ext cab

The hot cable coming off of my battery going back to power my fuel pump was shorting out against the hot exhaust manifold. Thus that caused the ECM-B fuse to blow. I didn't know the cable was burned to the manifold at first, so I first noticed the blown fuse and tried to replace it thinking that would immediately fixed the problem. But the instant I put the new ECMB fuse in, it immediately blew. I then traced back the hot wires and noticed that it was the wire that was shorting out against the manifold, so I wrapped it and re-insulated it.
I hope that somehow helps you, just thought I would share my problem because I have heard this problem before with Chevys (I am guessing because of the bad placement of the cable near the hot manifold).

rwbpls
12-14-2005, 09:41 AM
On my 99 suburban ecmb fuse blew because fuel filter stopped up and probably overheated fuel pump. Replaced filter, fuse, and fuel pump relay. Ecmb fuse not blowing now.

Add your comment to this topic!