Register and join the discussion

4T60E Transmission Shudder?


larryscope
08-14-2005, 06:10 PM
My dad's '92 Olds 88 exhibits a shudder or jerking at 80 - 100 kph (50-65 mph). It happens in overdrive under load such as light acceleration or going uphill. I believe it's related to the TCC. The SES light doesn't come on.

Is this most likely a mechanical wear & tear problem or an electrical problem? I've heard that the solenoid that applies the pressue for the TCC to lock up can go bad.

Also, there have been a couple of instances where under moderate to heavy throttle pressure at these speeds, the car doesn't downshift immediately. Before it does, you hear a 'whack' (sounds like you're locking or unlocking the deadbolt on your door) which you can feel also.

Does this more likely point to a mechanical problem?

Jim Adams
08-14-2005, 09:20 PM
the 4T60e trans is a complete electronic transmission that operates souly from input of vehicle speed sensors and other input and output sensrs,,,I know the light isnt on but try your Vehicle speed sensor it might be getting ready to go,,,it is the sensor on the passenger side of the car behind the engine oil filter on the trans,,has a 2 wire plug going to it,,also try disconnecting the battery and mashing on the brakes 3 times wait about 5 minutes then reconnect the battery. Good luck!!

larryscope
08-14-2005, 10:18 PM
also try disconnecting the battery and mashing on the brakes 3 times wait about 5 minutes then reconnect the battery. Good luck!!

What exactly does this do? Thanks.

razr_88
04-12-2007, 10:19 AM
yes i would like to know what that accomplishes as well...

maxwedge
04-12-2007, 12:51 PM
This thread is a year and 1/2 old. Please start a new one.

Add your comment to this topic!