Register and join the discussion

4 Wheel Drive not working HELP


TAKE-EM
04-19-2005, 09:27 PM
I have no light on my 4x4 selector knob and the envoy wont change from 2 wheel to 4 wheel. A local shop told me the computer may need to be reprogramed??

Any help with this problem would be appreciated. Also last weekend I accidentely ran my battery dead would this have caused it.

Thanks
Rick

ryanj44
04-19-2005, 10:34 PM
Rick,
Is there an orange light on your dash that say "service four-wheel drive" or an image of wheels with front turned and a wrench?? If there is either, there is something wrong with your four-wheel drive. You'll have to bring it in and have it serviced.. I've had the same problem on my '04 Ascender.
Good Luck.

TAKE-EM
04-20-2005, 06:37 AM
absolutly no lights at all.

TAKE-EM
04-20-2005, 09:31 AM
I just got a call from the dealer they say I need a new control module that mine is shorted out. $430.30 parts and labor. Also he said he cant test the switch until the module is chaged any suggestions.

Rick

ryanj44
04-20-2005, 06:20 PM
is your truck still under warranty?(3yr/36000mi?) If so, then you should not have to pay for the part.

03 lowered envoy
11-14-2005, 12:50 AM
pull the fuse for the 4wd system let the thing reset for 30 seconds then reinstall it. mine did this there is an update for the software the dealer can do. The problem is that the 4wd system forgets to wake up.

chasepicante
01-09-2006, 06:06 PM
I have no light on my 4x4 selector knob and the envoy wont change from 2 wheel to 4 wheel. A local shop told me the computer may need to be reprogramed??

Any help with this problem would be appreciated. Also last weekend I accidentely ran my battery dead would this have caused it.

Thanks
Rick

Discovered I had the same problem on 1/07/06. Pulled the diferential transfer fuse from the fuse box under the hood. Waited a minute and reinstalled it. 4x light came back on and the switch now works. Go figure-

zorro69
05-03-2006, 11:09 AM
I now have the same problem. Is the fuse you are talking about the one labeled 4wd in the interior fuse box. I don't have one labeled differential transfer in my 2002 panel.

hahgee
12-17-2007, 02:53 PM
You probably have this fixed by now or maybe not...

The module code is UC1000 and its connected to your 4wd, seat operations, air, heat, temp gauge, radio, etc... Almost everything.

Only a GM certified mechanic can work on this and what they do is reboot the module and it wakes back up generally 90% of the time. This costs around $90 and only takes a few minutes.

However, if this does not work then the module needs to be replaced and they said that would cost around 5 0r 6 hundred. Big difference but usually there is no price breaks if the reboot doesn't help they just charge for both.

Hope this helps anybody else with this problem...

maxwedge
12-17-2007, 03:51 PM
Please look at the dates before posting this thread is dead, thanks.

Add your comment to this topic!