Register and join the discussion

91 mustang 5.0 heater wont get hot. please help


thistang88
03-14-2005, 02:19 PM
Can anyone help me. I bought this 88 mustang with 91 5.0 HO, and the heater didnt work. I decided to put in a new heater core. I did and completed. I still get no heat. Changed the thermostat. Still no heat. Both heater hoses are hot but no heat. Checked all the vacuum controls under the dash and all seem to be working. The dampers open and shut. The car gets up to a good temp 195. I even put cardboard in front of radiator to get it extra hot. STILL NO HEAT. Setting in my garage running it gets a little warm but nothing like it should. Are there any valves that control the water flow ? Ive noticed when the engine is off and I take a heater hose of I dont get much fluid coming out. Should I? Sensors? Please help , its cold in NJ. I installed a 3 core radiator but it wasnt working with the stock one either so that isnt it ???? Please help

[COLOR=royalblue]

mus5.0tang
03-15-2005, 06:57 AM
might be the heater control valve.

thistang88
03-15-2005, 07:01 AM
might be the heater control valve.

Where is that located at? Can you get to it without taking the dash off? Thanks for the reply. This has been driving me crazy.

mus5.0tang
03-15-2005, 03:02 PM
on the passenger side on the upper heater hose that goes into the heater core. from what i hear its under the dash.

mus5.0tang
03-15-2005, 03:03 PM
you said you replaced your heater core. how did that go. i have an 88 gt that i need to do a heater core on.

thistang88
03-15-2005, 03:16 PM
you said you replaced your heater core. how did that go. i have an 88 gt that i need to do a heater core on.

Its not that bad. I Dont want to do it again though!!! I removed the whole dash unhooked the heater hoses from under the hood and then took the nuts off the ac canaster so i could get some room to open the lid where the heater coil is. I proped the lid open and took out the old one and installed the new one after scraping out all the old black sealant. I put new rtv black sealant in and put it all back together. I labled all the screws in baggies. I done this all myself on a sat and sunday. Not full days but steady. Its a pain dont get me wrong but i did it and it looks like the heater core wasnt even bad!!!! oh well.

thistang88
03-16-2005, 05:32 AM
on the passenger side on the upper heater hose that goes into the heater core. from what i hear its under the dash.
I think that valve is only on 4 cyl. The Heater hoses go to a different place on them.
Does anyone have a diagram of where the heater hoses connect on 88 to 93 5.0? The guy that had my car before me wasnt the smartest and maybe they are hooked up wrong. My hoses run like this: Facing the front of the engine, the one comming off of the small tube of the heater core (left side) is connected to the lower stem of my water pump. The big side of the heater core (right side) is coming out and going to the intake manifold. There is also a small hose that taps into this one and runs up and goes to the upper intake. Now if im not mistaken, it doesnt seem right. I think the big side of the core is supposed to be the inlet and the small one is the outlet, and the water pump, pumps the coolent thru it and out to the manifold. If so, hoses going to the core are wrong??? I just dont know. There is another port on the water pump , the top port which connects to the thermostat housing I think is the bypass. Maybe the two hoses on the pump need switched, but I think they are right. Can someone just look under the hood and see how they are run? That would help me. Please help.

importeater5_0
03-22-2005, 07:38 PM
i think my heater core is going and im soo scared, i dont wanna do that job lol, i hope my radiator just has a leak in it, my low coolant light comes on like a week after i fill the radiator, and i smell anti-freeze when i have my heat on, does this mean my heater core is dying? i still get heat though.

thistang88
03-23-2005, 07:00 AM
i think my heater core is going and im soo scared, i dont wanna do that job lol, i hope my radiator just has a leak in it, my low coolant light comes on like a week after i fill the radiator, and i smell anti-freeze when i have my heat on, does this mean my heater core is dying? i still get heat though.

Is your pass. Side floor wet? Usually its wet if your heater core is Leaking. Its not too bad to change , just have to take your time and mark where everything goes.

HiFlow5 0
03-23-2005, 12:42 PM
Heater cores are not all that bad. I have done a few, take a look at my write up.
http://www.dork.com/hiflow50/

importeater5_0
03-23-2005, 08:53 PM
i havent checked the floor yet(ima lazy bastard), but thats a sexy write up on how to do it ill probly be printing that out in a few weeks and using it.

Add your comment to this topic!