Register and join the discussion

no dash light-signals remain lit


Brandnew2003
01-18-2005, 12:37 PM
Fellow Ford owners! Help me please!

When I turn my headlight switch on at night I don't have a dash light and both blinkers are solidly lit. Everything works, I can't see my dash at night. The book says maybe a bulb is out. I've checked and rechecked and it apears that all my bulbs are ok. Any idea's?

denisb
01-18-2005, 03:15 PM
Bad ground maybe? I've seen where you have a park/brake light assembly and you get a bad ground it can give you freaky outcomes.

micky50
04-30-2005, 12:29 PM
Fellow Ford owners! Help me please!

When I turn my headlight switch on at night I don't have a dash light and both blinkers are solidly lit. Everything works, I can't see my dash at night. The book says maybe a bulb is out. I've checked and rechecked and it apears that all my bulbs are ok. Any idea's?
Iam experiancing the same problem with 01 taurus--both blinker lights staying on and no dash lights although blinkers work fine but no dash lights ckd ground cable seems ok-my car does it intermintly--usually once every 2 months or so usually last a few hours then goes back to normal--?????????

Taurus2002SEL
05-13-2005, 01:06 PM
Same thing with my 2002 Taurus SEL. Outside car lights are all fine just inside black except for solid lit delt signal lights. I drive about 50 km and poof all dash lights come on again. This usually happens when wet, raining, snow or basically too much water around so there must be a short somewhere. The lights come on only after driving awhile and the car "drys out". Again not a master mechanic!

rysarivers
02-16-2006, 12:27 AM
my 2002 ses does the same thing, it was only every once in a while, but now it is all the time. Did anyone get it fixed????????? Drives me crazy!! Especially at night, i can't tell how fast i'm going, i have to turn on the over head. ANNOYING

Taurus2002SEL
02-19-2006, 04:46 PM
We have the answer...finally! Problem was within the Cluster Grid...need to replace faulty printed circuit Part # F01F1Z-10K843-AA and part price is about $30.00 US and labor is $150.00 US rated at 2 hours cause of dash set up and inaccessable location designed to keep mechanics employed & part of the greater Ford conspiracy to get everyone to pay for their car twice.

02taurus_sel
02-19-2006, 09:40 PM
I have 02 Taurus SEL,same problem, but intermittant.
Initially I had planned to replace headlight/dimmer switch, but after a few
days mine came back on.been OK since.
My research found there may be a loose pin on wiring connector to
printed circuit at rear of instrument cluster.

seasonalskier2006
02-21-2006, 08:34 AM
We have the answer...finally! Problem was within the Cluster Grid...need to replace faulty printed circuit Part # F01F1Z-10K843-AA and part price is about $30.00 US and labor is $150.00 US rated at 2 hours cause of dash set up and inaccessable location designed to keep mechanics employed & part of the greater Ford conspiracy to get everyone to pay for their car twice.

that fixed my car! thanks so much! though the $150 estimate of time was a little much in my case. The mechanic had the whole thing done in 45 min (previous master mechanic of ford :icon16: ) so it is possable to get it done quicker if you shop around! tip for all of yall who want to go the mechanic route vs. the do it yourself way.

horners87pa
07-09-2010, 03:44 PM
just fixed this on a 02 taurus, i went to the junk yard with a 7mm, 8mm, and the factory deck removal clips, i took a instumment cluster out of a 2000, the bottom portion where the shift indicator is can be changed easily if needed with the original one. The new one required 2 light bulbs and i payed 20 bucks for it. Also i had an engine dtc for the keep alive memory which has never come back either. It takes 15 mins to remove the cluster. Save some cash..... Hope this helps ...... Dave

PTG1212
07-26-2010, 09:38 AM
2002 SES with same issue. Been there ever since I bought the car. Once or twice a year (may be getting more frequent) car starts and no dash lights. If I bang the dash above the instrument cluster lights all come back and it will be fine for months. Usually one modest smack to the dash fixes it. Someone above spoke to a possible faulty pin connection. I have suspected that all along. Hopefully banging the dash will continue to work but a least I have an idea of the issue now.

Erik2002Winnie
08-02-2010, 09:41 AM
our 02 does this as well.


i found a free remedy

whack the top of the dash with your hand, the curved top of the cluster.

works everytime. :evillol:

Add your comment to this topic!