Register and join the discussion

wipers/speedometer/tachometer/radio


dan chak
11-03-2004, 09:43 PM
ok. first the radio and clock died a year ago. I didn't care, because I was dealing with a host of other problems with my car. now, all at once, the wipers, speedometer and tachometer decide not to work anymore. makes driving in the rain and snow all the more exciting. HELP!! any ideas?

93shoblkmtx
11-04-2004, 12:37 AM
fuses?

dan chak
11-04-2004, 07:04 AM
fuses? I checked all of the fuses under the hood (the ABS fuse was blown, replaced it and I guess my brakes are safer now) and checked the fuses my owner's manual (which is for a '99 Taurus for some reason) said were the ones for front wiper and tach and speedometer. they seemed fine. will try again, but these two seperate areas went dead at the same time... I don't think it's fuses.
thanks for the response.

doug handy
11-04-2004, 12:27 PM
I have a similar problem. The radio and clock will go out along with the wipers and the power door locks will unlock and lock. I found the other morning that the turn signal would cause them to come back on???

drdisque
11-04-2004, 04:46 PM
the fuse thats out is not located under the hood, its located in the smaller fuse panel in the drivers side footwell

dan chak
11-05-2004, 07:35 PM
the fuse thats out is not located under the hood, its located in the smaller fuse panel in the drivers side footwell we checked those fuses today and all appear fine. however, if I turn the key to the ignition to accessories, the wipers then work fine. if I don't touch the wipers after turning the key to accessory, then the tachometer and speedometer will work... sometimes... sometimes for long times even.
I really cannot afford to take this to a mechanic, with my budget, but it's also the only car I have.

doug handy
11-05-2004, 08:31 PM
Does this occur only when your headlights are on?

dan chak
11-05-2004, 11:38 PM
whether the lights are on or not, the wipers do their weird thing of only working when key is in accessory position. as for the tachometer and speedometer coming and going when they chose (after I have done the thing with the key) that doesn't seem to matter as far as the lights being on either.
Why?

doug handy
11-06-2004, 06:46 PM
my speedometer and tach are fine but the wipers and radio will go off sporadically and it seems to be only when the headlights are on that this happens.

shoot2much
12-19-2005, 09:22 PM
I had a problem a couple of months ago where my daytime running lights were literally staying on all day and draining my battery. I pulled the fuse for my running lights and things were great. Today, my daytime running lights were on but my headlights won't come on. I tried the fuse back into my daytime running lights connection and my dash and running lights work. Daytime running lights stay on all of the time + Dashlights = I can't turn my lights off at all. Headlights turning on and off = I have no dash lights.

alex boss
12-22-2005, 01:17 AM
I had a problem a couple of months ago where my daytime running lights were literally staying on all day and draining my battery. I pulled the fuse for my running lights and things were great. Today, my daytime running lights were on but my headlights won't come on. I tried the fuse back into my daytime running lights connection and my dash and running lights work. Daytime running lights stay on all of the time + Dashlights = I can't turn my lights off at all. Headlights turning on and off = I have no dash lights.

Bit of a hijack, but you probably have a bad headlight switch. easy to replace.

alex boss
12-22-2005, 01:24 AM
Dan-seem to remember several posts on here dealing with similar probs. If you haven't already, try a search for tach and speedo problems- seems like the fix was a new Vehicle Speed Sensor (VSS) which cleared up a bunch of wierd problems. I may be wrong but search is free. Alex

Edit-Also try Control Module in search, I think thats your fix. The module is not the ECM. This one controls a variety of electric components. I think it is located on the drivers side of the radiator mount in the engine compartment, Hope my old brain is of help. Good luck, Alex

Add your comment to this topic!