Register and join the discussion

squeaky belt/ pulley noises


gravedigger03303
03-09-2004, 01:33 PM
i have 96' tahoe with a vortec 350. when ever the engine runs the belt or the pulleys squeak. i've tried belt dressing but that does no good. the sqeak is a chirping type sound and you can hear it at all speeds unti the motor itself drowns out the sound. can anyone help?? thanks

Stymie
03-09-2004, 04:16 PM
digger, I had some squeaks in pulleys....could not pin it down with all the engine noise so I shot some white lith grease through one of those red straws onto the back of pulley's until I found the one. Careful not to squirt onto the belts.
Regards,
Stymie

gravedigger03303
03-10-2004, 07:22 AM
digger, I had some squeaks in pulleys....could not pin it down with all the engine noise so I shot some white lith grease through one of those red straws onto the back of pulley's until I found the one. Careful not to squirt onto the belts.
Regards,
Stymie

thanks! i'll try that next.

!thumper
04-14-2004, 03:00 PM
I have 96,000 miles on my 96 Tahoe and I just replaced the belt and the whole tensioner pully with arm and all is well. I would check and inspect your tensioner pully.

BowtieFreak
05-21-2004, 08:02 PM
I would check the pulleys. Take the belt off and spin the pulley by itself. If it spins freely it's bad, but if it stops quickly it good. If the pulleys are good, then check the tensioner. Or the belt could be going bad. If there are any cracks or worn spots get a new one. But if all that checks out, could be the pulley for the altenator, a/c compressor, waterpump, or power steering.

Add your comment to this topic!