Register and join the discussion

i still can't get help on why my mazda won't start...


92pro
10-05-2003, 07:51 AM
ok i bought a mazda that will sometimes start and run great, but 99% of the the time it just cranks.. I checked all the obvious and it wasn't getting spark etc, so i tested all the ignition stuff. Thats when I noticed that the check engine light doesn't come on when i flip the key to the "run" position. IF and very rarely IF the check engine light does come on then the car starts with no problem... Now I checked grounds to the computer, even tried replacing the computer... I know it gets 12 volts from at least one wire going in... anbody happen to know if thats enough?? ITs a 92 protege with the sohc and 5-speed if that matters.... please help save a mazda from destruction as i have a temper >:( lol

Sexy beast
10-07-2003, 10:18 AM
Take it to the mechanic, they have all the gizmos to do electronic checks. You are capable of screwing up the electronics yourself by poking around.

MazdaB1300
11-18-2003, 10:24 AM
Although it's not very likely, it could be in the connection in your ignition switch. The starter circuit could be good but the rest may have a bad connection of some sort. That's just a suggestion

my13waysused
02-14-2006, 03:56 PM
I seem to be having the same problem with my 1993 Mx-3. I have never had a major problem with this car and it has 176xxx on the odometer. One day i pulled in the driveway, and tried to start it about 10 minutes later, and it cranks but refuses to start. I also noticed the check engine light will not display when the key is turned to start. I thought the computer wasn't getting power, so I checked grounds and wires and found nothing. I replaced the distributor 2 times -with used but good ones, rotor, spark plugs, plug wires, coil, ignition module and I still have the same problem...it refuses to start up and is getting no spark
I know it isn't the fuel pump...ive checked that...what could it possibly be??

rjitzsu
02-27-2006, 09:45 PM
no spark on an early protege = distributor
9 times out of 10

lchapman
06-09-2007, 02:46 PM
i have a 1993 mazda b2600i and sometimes it will start and sometimes it won`t. I have changed the distributor a couple years ago and the wireing harness from behind the switch down the stearing colum an a used ignitor just last week and it still wont` start every time. Any help would be appreciated.

Somebody1
06-15-2007, 10:47 AM
Someone had the same problem here, I think there was a thread about the fix.http://www.coremazda.com

bigeric
10-12-2007, 01:37 PM
My mazda ran out of gas about a year ago and has been siting. Now it wont start. P.S. I did put gat in it. What to do???

Add your comment to this topic!